
A Bigger-Than-Big 
Treasury  

               of Excel Tricks 
 
 
▲Excel web queries have changed 
Data stored in defined web page tables is now more accessible directly. From the Data tab, 
in the Get & Transform Data group, click From Web. Navigate to the web page that has the 
data you need. It may take a few moments to connect. You might also navigate there first, 
then copy/paste the URL in the From Web dialog. Now select from the tables listed. You’ll 
see a preview on the right. Click Load at the bottom right. You have created a refreshable 
query and can now use that data in your workbook. 
 
▲Cleaning up dates 
Do you get import files with funky dates? For example, are month, day and year separated 
by a period (.) or only spaces? It might take some maneuvering, but you can probably 
disassemble, then reassemble it with text functions. So, if you were given 12.31.2019 in cell 
A1 and needed 12/31/19, you could disassemble it with =LEFT(A1,2) to get the month, 
=MID(A1,4,2) to get the day and =RIGHT(A1,4) to get the year. Now, using the DATE 
function, reassemble it. You could do it all in one formula like this: 
=DATE(RIGHT(A1,4),LEFT(A1,2),MID(A1,4,2)). The syntax of DATE is year, month, day. 
 
▲Shape up data 
There are many tools to help you squeeze information out of your data, but it needs to be in 
the right shape. Be sure your data has column headers, a description of what’s in each 
column. Next, click in the middle of your data and press Ctrl+A. This should select all of 
your data. Scroll all the way down with the scroll button on the right. It should stop at the 
end of your data. Next, turn Filter on, or use the shortcut Ctrl+Shift+L. Dropdown arrows 
should appear at the top of each column. If so, you’re ready to go! 
 
▲Creating maps 
Did you know that you can create maps from geographically recognizable data in Excel 
using standard country/region, state/province, county or postal code? It works best with 
states and countries/regions. Standard abbreviations such as states in the U.S.A. or 
provinces in Canada can be used in place of the full versions. Highlight the location data 
and the value data you wish to show. Try a 3-D map, too. This allows you to show values as 
3-D columns rising out of a more geographically detailed map. Assembling one is a bit 
more involved, but worth it if your data needs this kind of display. 
 
▲Did you know that Excel is clairvoyant?  
FlashFill tries to detect how you want to separate data that has been combined in a cell. 
Let’s say a cell contains the data Chicago, IL 60625, and the cell below it contains the data 



New York, NY 10007. If  in the next column on the same row you type 60625, then just a 1 
in the next row, FlashFill guesses that you want 10007. It will do this for all following rows! 
Just press Tab and it will complete the new column. If it doesn’t recognize the pattern, type 
an additional character. 
 
▲Creating dates  
To show a report title that has the current date or a specified “as of” date, on a separate 
worksheet, in cell A1, type =TODAY(). Leave B1 blank, but highlight it a different color. This 
is where a custom “as of” date will go. In C1, type: =IF(B1=””,A1,B1). Name C1 something 
like As_Of_Date by clicking in the Name Box and typing the string (no spaces in range 
names). Your report title then would be a formula like: =”2018 Financials as of 
“&As_Of_Date. Whenever you want to change the date, click in the Name Box and choose 
As_Of_Date to navigate there. 
 
▲Keyboard Shortcuts  
Ctrl+Shift+3 – Dates may change to serial numbers when imported. Use Ctrl+Shift+3 
(#) to change serial number dates formatted as numbers back to dates (43160 becomes 1-
Mar-2018). You can then apply any other date format. 
Ctrl+Shift+2 – Imported time stamps sometimes show up as decimal values. Change 
time expressed as a number with Ctrl+Shift+2 (@). For example, .5 would become 12:00 
PM. 
Ctrl+Shift+` – Use Ctrl+Shift+` (~) to change any formatted numbers back to general 
format. For example, this would change 1-Mar-2018 to 43160, and 12:00 PM to .5. 
 
▲Connect cells with CONCAT  
A new function that’s useful is CONCAT. Like CONCATENATE, it creates a single string from 
the contents of several cells. But, CONCAT lets you specify a range. For example, if cells A1 
through C1 had values of 1, 2, 3, respectively and you wanted to show 123 in a single cell, 
the CONCAT function would be =CONCAT (A1:C1). CONCATENATE would be 
=CONCATENATE(A1,B1,C1). Perhaps not a big deal with 3 cells, but imagine 10! While you 
can also use & (=A1&B1&C1) to get the same thing, CONCAT has the same advantage when 
the cells to be connected are consecutive. 
 
 

▲ Make your dashboards interactive  
Sometimes it’s too hard to include everything that a reader might want to examine for 
decision support. One way to present more information concisely is to add some interactive 
features, allowing the reader to dice, slice and customize what is being reported. Here are 
three tools that can do just that if you use pivot tables and pivot charts in building 
dashboards. 
 
Slicers 
Slicers are a way to filter your pivot table report by any field. Using multiple Slicers can also 
provide information as well as filter. Let’s begin with a single Slicer first. Here are the steps: 
 



1. From inside the pivot table, click into the Pivot Table tools Analyze (Options in Office 
2010) tab. 
 
2. In the Filter group, click the Insert Slicer button. You can also find the Insert Slicer button 
on the Insert tab. 
 
3. Select the field you wish to apply to the Slicer. 
 

HINT: If you don’t see your fields, but a list of data 
connections, close the dialog box and click into any one cell 
of data inside the pivot table, not in a blank cell outside it. It 
will normally default to somewhere in the middle of your 
worksheet. 
 
One way to make it easier on the eyes is to insert a blank 
column to the left of column A and drag the Slicer over 
there. Should your pivot table grow and change as a result 
of clicking on the Slicer, the Slicer itself won’t move. 

 
 
Adding a second Slicer gives added 
functionality. You can see in the diagram that 
when you filter for something in one Slicer, it 
only shows you the filtered available fields in 
the second Slicer. 
 

Use the Slicer Tools contextual tab to apply different colors to multiple Slicers for better 
visual cues. (Available in PC Office Versions 2010 and Mac Office 2016.) 



 
Report Filters 
Report Filters actually do what Slicers do. They’ve just been doing them longer! While 
slicers are visually appealing and easy to use, Report Filters are more robust. Let’s talk 
about how to add one, then what it can do. 
 
1. From your Pivot Table Fields panel, drag the field you wish to use to Report Filter to the 
upper left quadrant of the layout area. 
 
2. Select the field or fields to filter by in the area provided above your pivot table. 
One thing that Report Filters can do that Slicers can’t is search for your filtering criteria. So, 
if you have large lists from which to filter, a Report Filter may be more useful than a Slicer. 
(Available in all versions of Excel on both PC and Mac.) 
 
Timelines 
Timelines were introduced in Office 2013 and are another type of slicer. You insert it the 
same way, but it will only offer the fields that contain valid date data. 
 
If you don’t see a field listed that you believe should be, it’s likely that while the data might 
look like dates, it is not formatted that way. An easy check to make is to clear the formats 
on the cell. A proper date will go back to its serial number form, while a text string will 
remain the same. 
 
Slicers and Report Filters will also affect the content of charts and graphs created from the 
same pivot table. 
 
Tip: Be sure to put instructions on your dashboards, letting readers know how to use them 
to create the exact views they need. 
 
 
 
 
 
 
 
 
 
 

▲ This does not compute! Excel error messages  
 
Q. I just opened my workbook and saw a bunch of #REF errors. What happened? 

A. #REF means that a Formula refers to a worksheet, 
column, row or workbook that Excel can’t find. Moved, 
renamed? The most likely explanation for your 
situation is that a workbook to which this one refers 



has been moved to a different location. Something to try is to click on the Edit Links button 
in the Data tab. It might be easier to recognize what changed by seeing them all listed. You 
can fix the broken links from this dialogue box. 
 
If your workbook is not linked anywhere outside itself, see if you can tell if any worksheets 
have been deleted. These are the most common reasons to see a #REF. 
 
Q. I occasionally get a #NAME error in my formulas. What does that mean? 
A. When Excel gives you a #NAME error, it is telling you that you have specified a named 
cell or named range of cells to use in a formula. If you don’t know what that is or haven’t 
defined any named ranges, then you probably have a typo or missing punctuation mark in 
your formula. For example, if you intended to write SUM(A1:A3), but dropped the 8colon, 
so it actually read SUM(A1A3), Excel is looking for a named range called A1A3. SUMA1A3 
would also give you the same error. 
 
When you see a #NAME error, first look for typos. If you have actually defined a named 
range, then click the dropdown arrow in the name box to see if Excel can identify it. 
 
Q. I keep typing in a formula, but it doesn’t calculate anything. It just shows the 

formula. What am I doing wrong? 
A. There are two explanations. First, the column you’re typing 
in may have been formatted to be text. Just look in the Number 
Format field in the Number group on the Home tab. If it says 
Text, change it to General or Numbers. 
 
The other reason might be that you have toggled Show 
Formulas to on. The shortcut to turn Show Formulas on is 
Ctrl+`. The grave or backward quote mark is found on the same 
key as ~ or tilde. If you were trying to use Ctrl+1, or thought 
you had the Shift key down when you pressed 1 to get the 
exclamation point, but instead had Ctrl pressed, you could have 

accidentally pressed the key just to the left of that 1 key. To toggle it off, press Ctrl+` or click 
on the Show Formulas button on the Formulas tab in the Formula Auditing group. 
 
 
 
 
▲ AND, OR and IF  
If you’ve worked IF function logic into your Excel toolkit, you can extend its usefulness by 
adding the AND or OR functions to it. Let’s take the logic for the age group, 45 to 55. If we 
want to identify these as “Target Market” and we have the age number stored in column D, 
our formula would look like this: =IF(AND(D2> =45,D2<=55),”Target Market”,””). With 
AND, both conditions must be true. If we wanted to show only individuals who were in 
Florida or Texas, and the 2-letter state code was stored in column E, our formula might 
look like this: =IF(OR(E2=”FL”,E2=”TX”,”X”,””).=IF(OR(E2=”FL”,E2=”TX”,”X”,””). 
 



▲Mail Merging from Excel to Word: Watch out for number formats  
Mail Merging from Excel to Word can be tricky when your number formats need to be 
precise. If you are using a calculation to come up with a number that you want to use as a 
merge field in a Word document, you might need to format the number as text with a 
formula. With numbers resulting from formulas, the formatting in Excel doesn’t carry over 
to the merged Word document. This formula, for example, will convert the value of 10 in 
cell A1 into $10.00: =TEXT(A1,”$##.00”). You can also “wrap” a formula in the text function 
(=TEXT(A1+B1,”$###.00”). 
 
▲Meeting tracking status in Outlook and Excel  
Whether you need to create a mail merge for name badges, a sign-in sheet or some other 
tracking tool from your meeting acceptance data, versions of Outlook from 2010 forward 
allow you to capture meeting tracking status to the clipboard. From inside the meeting item 
(meeting that you arranged), click the Tracking button (Meetings tab, Show group). This 
will drop down two selections: View Tracking Status and Copy Status to Clipboard. Now, 
open Excel. Click in cell A1 and click the Paste button or use Ctrl+V. Use the data as you 
would any other Excel list data. 
 
▲See your SharePoint data  
When list and library views don’t look familiar because of an interface change, if you are 
even a basic Excel user, it’s a breeze to see your SharePoint data in Excel. From a 
SharePoint list, click the List tab and Export to Excel from the Connect & Export group. You 
may also see that option above your list in the newest look of SharePoint Online. You can 
do this for your libraries, too! It’s the same process; however, in the newest experience in 
SharePoint Online, you will need to click Return to classic SharePoint to easily find this tool. 
 
▲2 ways to perform lookups  
If you want to start a war, get two veteran Excel geeks to argue over VLookUp versus 
Index/Match to perform lookups. While the difference between the approaches might be 
minute, Index/Match has an edge. VLookUp requires the lookup value to appear in the first 
column, period. Index/Match doesn’t even require the lookup value to be in the same table 
as the result! Nor does it require that you identify all the table columns and rows—just two 
ranges, the result range and the lookup range, for the Match portion of the formula, making 
it more efficient and a bit faster. 
 
 

▲ Sheets vs. Excel: Is there a battle?  
There is a battle going on, for sure. But, it’s more for hearts and minds now that the playing 
field has been somewhat leveled. With both productivity software behemoths offering free 
online productivity software for documents (Google Docs – Microsoft Word Online) and 
presentations (Google Slides – Microsoft PowerPoint Online), and with both offering free 
shareable cloud storage (Google Drive – Microsoft OneDrive), the arguments are down to 
what you need and what you like to use. 
 



The old battle cry of Google used to be that Sheets was free. Microsoft has risen to that 
challenge. Then, it was the collaborative nature of Google Drive. Now Microsoft enables that 
same functionality in OneDrive. Microsoft fought back with its robust desktop apps, which 
could be run whether or not you were connected to the internet. You can now run Google 
apps locally, too, internet or not. So, here are a few points to ponder when choosing a 
spreadsheet solution for your organization. 
 
The featherweight champ 
Google Sheets is still a lighter-weight app than Excel, even Excel online. If you don’t require 
the more advanced features of Excel, you’ll find that Sheets starts faster and is slightly 
quicker on selecting actions. 
 
One place where Sheets just edged out Excel online is pivot tables. You absolutely cannot 
do one in the current version of Excel online, but you can in Sheets! Granted, the 
functionality of Sheets pivot tables is nowhere near Excel desktop, but it is a longstanding 
argument that has just lost a little steam. Sheets loads 1,000 rows initially; Excel online, all 

1,048,576. 
 
Functions and formulas 
There are 112 functions in Excel that are not in 
Sheets. Likewise, there are 53 functions that are 
Sheets specific and not included in Excel. All told, 
there are 472 native Excel functions and 413 
Sheets functions. The race is a lot closer than it 
used to be. The advanced Excel user might be 
missing these in her arsenal if she had to work in 

Sheets over Excel desktop. 
 

 IfNA: replaces the specified value if the lookup function performed results in 
#N/A 

 FormulaText: translates a formula into a text representation 
 GetPivotData: retrieves a data point in a pivot table 

 
 
 

 
Chart choices 
Sheets now offers map and gauge charts, which could be 
useful for creating dashboard functionality. Other than 
that, the choices are limited to the standard chart types 
also shared by Excel Online. That said, nothing is a match 
to Excel desktop for robust and flexible chart 
functionality. The combinations and permutations of 
chart choices seem limitless. You can also save your chart 
creation as a template. 
 



Longing for the old days? 
If you miss your dropdown menus, using Sheets will feel more like home. They have not 
moved to a ribbon interface like you will find in online and desktop versions of Office. 
 
Bottom line 
Either online spreadsheet program will function for all but the advanced user. 
Transitioning an entire organization to G-Suite or GoogleDrive will leave your Excel ultra-
geeks out in the cold. With cost savings no longer being an issue and the same with 
collaboration, transitioning from Office to Google might not be worth the training pain. 
 
▲Inserting spreadsheets in OneNote  
In OneNote, you can insert a spreadsheet that opens in Excel. It is stored as an embedded 
object. In other words, the only place it lives is in the notebook. But, it opens in Excel with 
all of its robust features. If you just need to enter data in tabular format, insert a plain table. 
However, if you need formulas and conditional formatting, for example, an embedded Excel 
worksheet is best. On the Insert tab in OneNote you’ll see the Spreadsheet button in the 
Files group on the Insert tab. Hover over the object for the Edit button. 
 
▲ Text is text is text  
If a cell is formatted as text, no matter what’s in there, it will be interpreted as text. On the 
Home tab in the Number group, there’s a field showing the cell type. If it says text, change it 
to either Number or General to get the data in it to behave as you expect. If that’s not the 
problem, numbers may simply be stored as text. In a new column enter a formula as 
=VALUE(TRIM(A1)) to get rid of leading and trailing spaces, as well as convert text-stored 
numbers to values. Do a copy/paste values to complete the repair. 
 
▲PowerPoint and Excel: Embed or link?  
It can be confusing to decide between embedding and linking Excel charts in your 
PowerPoint presentations. Embedding a chart means that the underlying workbook that 
was used to create the chart will be compressed and added to the presentation. You see the 
chart, but when you right-click and choose Edit Data, it will open its embedded copy of the 
entire workbook. This works well for sending presentations among co-workers who may 
be editing the chart. If they don’t need to edit it, or you are sending it outside the 
organization, it’s better to use the link options or paste picture. 
▲More Keyboard Shortcuts! 
Ctrl++ – Use Ctrl++ (plus) to insert cells (if clicked on a column, inserts column; if clicked 
on a row, inserts row). Another way to express this shortcut is Ctrl+Shift+= . This keyboard 
shortcut combination may also work with the + on the 10-key pad. Select multiple columns 
or rows to insert multiples. 
Ctrl+- – Use Ctrl+- (minus) to delete cells (if clicked on a column, deletes column; if 
clicked on a row, deletes row). Also may work with the – on the 10-key pad. Select multiple 
columns or rows to delete more than one at a time. 
Ctrl+! – Use Ctrl+! to change the cell format to number. Another way to express this 
shortcut is Ctrl+Shift+1. By default it sets the decimal places to 2. While it will set the cell 
type to Number, if the cell contains text, it does not alter it. 
 



▲Formulas with pivot table data  
Wait! Don’t run away! I know those terms—formulas with pivot table data—can seem 
intimidating to some, but hang in there a moment while we cover what we’re really doing 
there. 
 
Let’s begin with a simple formula: 2+2=4. If this were in Excel, we might have 2 entered in 
column A, row 1 and also in column B row 1. So, if we type an = sign in column C, row 1, 
then click on A1, type a + sign, click on B1 and press Enter, we’ll get 4. The formula we 
would have just created would be =A1+B1. 

 
While what we create here might seem a little 
more complicated, it’s really not. 
Now, pivot tables. Don’t be afraid of the term. 
It’s just a custom table writer that quickly 
sums up or aggregates the numbers we ask it 
to based on some criteria. So, for example, 

total up all the purchases by customer type for a particular account type. Beginning with a 
well-built list (one row per record, data arranged in columns with column titles, no blank 
columns, no completely blank rows), we click in one cell with data in it. 
 
Then, on the Insert tab, click on the PivotTable button. It’s the first one on the left. Now, just 
pick the columns (fields) you need and use the layout area to put things where you want 

them on the report. 
 
While it’s true that there is a lot more to both formulas and 
pivot tables, this will suffice to cover our topic: formulas with 
pivot table data. 
 
Pivot table references in formulas 
When we look at the pivot table created by these selections, we 
notice that we get totals for each Customer Type at the end of 
the row. 
 
If we wanted to create the total of customer types CONTRACT 
and MONTHLY, using our 2+2 example above, we might click 
into C11 and type an = sign, then click in C5, type a +, then click 
in C7. But, we’d likely get this instead of =C5+C7: 

 
=GETPIVOTDATA(“Purchases”, $A$3,“CustType”,“CONTRACT”) 
+GETPIVOTDATA(“Purchases”, 
$A$3,“Cust Type”,“MONTHLY”) 
 
Wow! Right? So what does all that mean? Well, like a graph, the number in C5 is an 
aggregate total of Purchases for the MONTHLY customer type and whatever Account Type 
we selected in the pivot table. Let’s look at that reference: 



 
“Purchases”,$A$3,“CustType”, 
“CONTRACT”  
 
If we consider that A3 or $A$3 contains all the information about this pivot table, then this 
makes sense. The good news (if we can get past the size of the data reference) is that even if 
we sort this pivot table in another way, we will still get that result. This comes in handy 
when you want to use these GetPivotData references on other worksheets. 

 
 
If you want to see another Customer Type, you could 
just easily change the formula.  
 
So, for example, if I have 
=GETPIVOTDATA(“Purchases”,$A$3,“CustType”,“
CONTRACT”) with a value of $73,791, then changed 
“CONTRACT” to “LOC-OND”, I’d get $64,357. I would 
not need to go back and click on that cell in the pivot 
table; instead, I just change the text in the statement. 

Whether you’re thinking of using this for dashboards or to create factors for calculations on 
other worksheets, it pays to get past the size of the GetPivotData references to get durable 
formulas. 
 
If you decide that you just wish pivot table references behaved like regular cell references, 
they can! On the Analyze (or Options in Excel 2010) Pivot Table Tools contextual tab, on 
the left look for the Options button, click the small dropdown arrow next to this button and 
uncheck Generate GetPivotData. 
 
▲Clean up your lists for better functionality  
The full complement of Excel tools and data analysis functionality are available if you set up 
your lists the right way. First, create column titles on a single row. This can also be a helpful 
step when planning out how your data will be used. Create a column for each piece of data 
you either have or will need. Next, create single-row data records, meaning a full record 
populates one single row. Multirow records reduce the number of options you have. Make 
sure each column contains a single type of data (numeric, alpha/numeric, percentages, 
currency, etc.). The more consistent your data types, the more you will get out of formulas 
and pivot tables. 
 
▲Get acquainted with AutoFill Options  
You may have noticed the little box that pops up after using AutoFill to populate several 
cells by clicking and dragging. It’s the AutoFill Options box, which contains context-
sensitive options for what you just filled. For example, if you fill dates, you’ll have the 
option of filling days, weekdays, months or years. 
 



If you want to create a sequentially numbered list, type a 1, then AutoFill it down. At first, it 
shows a list of 1s, for example, but click the Fill Series option in the AutoFill Options box 
and it will change to a numbered list. 
 
▲Get custom columns into your .csv file  
Outlook is a database. So, you can export data to a .csv file for analysis and scrubbing in 
Excel. However, it is not perfect. For example, you cannot export any custom columns you 
may have created. Only the standard ones will be in the .csv file. However, you can 
copy/paste from a view that contains the data you want. 
 
This is a great solution if you support someone else and want to work with their calendar 
data. Just be sure to view it as a list, first. Press Ctrl+A in the Outlook view, then paste to a 
blank Excel worksheet. 
 
 

▲Excel options: 3 questions  
 
Cursor to the right 
Q. Normally when I enter data, I enter across and not down. However, when I press 
Enter, it automatically goes down instead of across. Is there any way to change that? 
A. There is! Click File, Options, and Advanced. The first check box allows you to choose 
whether the cursor moves down, to the right, left or up when you press the Enter key. Set 
this to Right to make your cursor go where you want it to. 

 
Depending upon how long you’ve been using the Enter 
key in Excel to move to the next cell, it may take some 
getting used to. If you’ve always reached for the mouse 
to navigate back up and right to the cell you were just 
editing, it can be a bit frustrating. Give it a few days. 
Soon, the inconvenience will be replaced by the ease of 
having things work the way you like them to. 
 

 
Oops! Changed my mind. 
Q. I ignored a bunch of green error triangles, but now I’m not sure I should have. Is 
there any way to reset those once you’ve ignored them? 
A. You bet! In options (File, Options) click the Formulas category on the left. Look in the 
Error Checking section for the Reset Ignored Errors button. Click that, and your green 
triangles will all come back. 

 



 
AutoFill Options missing 
Q. My co-worker can copy formulas down by clicking and dragging from this little 
box in the lower right corner of the cell. Why don’t I see this on my screen? 
A. This option may have been turned off to avoid screen clutter. You can turn it back on by 
clicking on the File tab, selecting Options and then Advanced. The third check box down 
reads, “Enable fill handle and cell drag and drop.” Checking this box will make that small 
box in the lower right corner of a cell you’ve selected appear. Using this to AutoFill down 
will cause an AutoFill Options box to appear, where you can select context-sensitive 
options to affect what you’ve just filled. 
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